Overview
A data model in Rippling represents a core business entity (such as an employee, worker, company, or department) and defines how that entity’s attributes are structured.
Rippling’s data models interact to establish organizational relationships and hierarchies beyond basic reporting chains. Understanding how these entities connect helps you query endpoints and build efficient API integrations.
Requirements
- The Rippling API SKU
- An API token
Core models
User
A user is the authenticated persona for an employee at any given company. When the user is active, they will have one worker record that has a status of HIRED, ACTIVE, or ACCEPTED.
There may be instances, however, when one user has multiple worker records if they have been re-hired into the same company:
The user resource is modeled on the SCIM core user for standardization purposes.
User
Array [
]
Array [
]
Array [
]
Array [
]
Identifier field
Record creation date
Record update date
Whether the user is able to access company resources, typically when they are in actively engaged with the company and not after off-boarding.
The unique identifier across Rippling used by the User for direct authentication into their associated company. Globally unique.
name
object
The user's full name.
The given legal name of the user, or first name in most Western languages.
The middle name(s) of the user.
The legal family name of the user, or last name in most Western languages.
The preferred given name, or first name in most Western languages, by the user.
The preferred family name, or last name in most Western languages, by the user.
The display name of the user using either the concatenated preferred given and family name or username depending on availability.
emails
object[]
The user's email addresses.
A valid email address.
Possible values: [HOME, WORK, OTHER]
The classification of the email.
The display value of the email address.
phone_numbers
object[]
The user's phone numbers.
The canonical global phone number pursuant to RFC3966.
Possible values: [HOME, WORK, MOBILE, FAX, OTHER]
The classification of the phone number, pursuant to SCIM RFC 7643 4.1.2.
The display value of the phone number.
addresses
object[]
The user's addresses.
Possible values: [HOME, WORK, OTHER]
The classification of the address.
The formatted mailing address.
The full street address component, which may include house number, street name, P.O. box, and multi-line extended street address information, pursuant to SCIM RFC 7643 4.1.2..
The city or locality component.
The state or region component, pursuant to SCIM RFC 7643 4.1.2.
The zip code or postal code component, pursuant to SCIM RFC 7643 4.1.2.
Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]
The country component, pursuant to SCIM RFC 7643 4.1.2.
photos
object[]
The user's photos.
The URL of the photo.
Possible values: [PHOTO, THUMBNAIL]
The classification of the photo.
The User's preferred written or spoken language in the same format of the HTTP Accept-Language header, pursuant to Section 5.3.5 of RFC7231.
The User's default location for purposes of localization of currency, date time format, or numerical representations pursuant to RFC5646.
The User's current time zone in IANA database Olson format
The permanent profile number of the user.
Worker
A worker is a user who currently or has previously worked at the company. The worker represents the period of work for a user. On the worker object, you'll find references to other resources like Department, Employment Type, Legal Entity, and more.
Worker
Array [
]
Array [
]
Array [
]
Array [
]
Array [
]
Array [
]
Identifier field
Record creation date
Record update date
The worker's associated user.
user
object
Identifier field
Record creation date
Record update date
Whether the user is able to access company resources, typically when they are in actively engaged with the company and not after off-boarding.
The unique identifier across Rippling used by the User for direct authentication into their associated company. Globally unique.
name
object
The user's name.
The user's full name.
The given legal name of the user, or first name in most Western languages.
The middle name(s) of the user.
The legal family name of the user, or last name in most Western languages.
The preferred given name, or first name in most Western languages, by the user.
The preferred family name, or last name in most Western languages, by the user.
The display name of the user using either the concatenated preferred given and family name or username depending on availability.
emails
object[]
The user's email addresses.
A valid email address.
Possible values: [HOME, WORK, OTHER]
The classification of the email.
The display value of the email address.
phone_numbers
object[]
The user's phone numbers.
The canonical global phone number pursuant to RFC3966.
Possible values: [HOME, WORK, MOBILE, FAX, OTHER]
The classification of the phone number, pursuant to SCIM RFC 7643 4.1.2.
The display value of the phone number.
addresses
object[]
The user's addresses.
Possible values: [HOME, WORK, OTHER]
The classification of the address.
The formatted mailing address.
The full street address component, which may include house number, street name, P.O. box, and multi-line extended street address information, pursuant to SCIM RFC 7643 4.1.2..
The city or locality component.
The state or region component, pursuant to SCIM RFC 7643 4.1.2.
The zip code or postal code component, pursuant to SCIM RFC 7643 4.1.2.
Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]
The country component, pursuant to SCIM RFC 7643 4.1.2.
photos
object[]
The user's photos.
The URL of the photo.
Possible values: [PHOTO, THUMBNAIL]
The classification of the photo.
The User's preferred written or spoken language in the same format of the HTTP Accept-Language header, pursuant to Section 5.3.5 of RFC7231.
The User's default location for purposes of localization of currency, date time format, or numerical representations pursuant to RFC5646.
The User's current time zone in IANA database Olson format
The permanent profile number of the user.
Whether the worker is a manager
The worker's manager.
The worker's associated legal entity.
legal_entity
object
Identifier field
Record creation date
Record update date
The tax identifier for the legal entity.
country
object
The country the legal entity is based in.
Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]
The code of the country.
The legal name of the legal entity.
Possible values: [PARENT, SUBSIDIARY, BRANCH]
The legal entity's level in a hierarchy. * PARENT: The legal entity is considered the ultimate holding entity. * SUBSIDIARY: The legal entity is considered a subsidiary, fully or partially held by another. * BRANCH: The legal entity is considered a branch, associated with a parent legal entity.
The registration date of the entity.
mailing_address
object
The mailing address of the legal entity.
Possible values: [HOME, WORK, OTHER]
The classification of the address.
The formatted mailing address.
The full street address component, which may include house number, street name, P.O. box, and multi-line extended street address information, pursuant to SCIM RFC 7643 4.1.2..
The city or locality component.
The state or region component, pursuant to SCIM RFC 7643 4.1.2.
The zip code or postal code component, pursuant to SCIM RFC 7643 4.1.2.
Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]
The country component, pursuant to SCIM RFC 7643 4.1.2.
physical_address
object
The physical address of the legal entity, if it differs from the mailing address.
Possible values: [HOME, WORK, OTHER]
The classification of the address.
The formatted mailing address.
The full street address component, which may include house number, street name, P.O. box, and multi-line extended street address information, pursuant to SCIM RFC 7643 4.1.2..
The city or locality component.
The state or region component, pursuant to SCIM RFC 7643 4.1.2.
The zip code or postal code component, pursuant to SCIM RFC 7643 4.1.2.
Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]
The country component, pursuant to SCIM RFC 7643 4.1.2.
The parent legal entity.
The parent legal entity.
Expandable field
Possible values: [PEO, EOR, COR]
The legal entity management type in the case of an employer of record (EOR) or professional employment organization (PEO). * PEO: The legal entity is considered a Professional Employment Organization (PEO). * EOR: The legal entity is considered an Employer of Record (EOR).
The company or organization associated with the legal entity
company
object
The company or organization associated with the legal entity
Expandable field
Identifier field
Record creation date
Record update date
The company's ultimate holding entity.
The company's ultimate holding entity.
Expandable field
A list of the company's entities.
A list of the company's entities.
Expandable field
physical_address
object
The physical address of the holding entity.
Possible values: [HOME, WORK, OTHER]
The classification of the address.
The formatted mailing address.
The full street address component, which may include house number, street name, P.O. box, and multi-line extended street address information, pursuant to SCIM RFC 7643 4.1.2..
The city or locality component.
The state or region component, pursuant to SCIM RFC 7643 4.1.2.
The zip code or postal code component, pursuant to SCIM RFC 7643 4.1.2.
Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]
The country component, pursuant to SCIM RFC 7643 4.1.2.
The email address used when registering this company.
The legal name of the company.
The doing business as name for the company.
The phone number for the company.
The name of the company.
Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]
The worker's country.
The start date of the worker.
The end date of the worker.
The worker's number within the organization.
The worker's associated work email address.
The worker's associated personal email address.
Possible values: [INIT, HIRED, ACCEPTED, ACTIVE, TERMINATED]
The worker's status within the organization.
location
object
Possible values: [REMOTE, WORK]
The type of location.
The work location, if the worker isn't remote.
The worker's employment type.
employment_type
object
Identifier field
Record creation date
Record update date
The display label of the employment type.
The name of the employment type for non-custom employment types.
Possible values: [CONTRACTOR, EMPLOYEE]
The classification of the worker by the company. * CONTRACTOR: Contractors are self-employed workers who provide services on a short-term or per-project basis and are not eligible for tax-withholding or benefits. * EMPLOYEE: Employees are hired and managed by an employer, work under the employer's direct supervision and control, and are protected by law for wages and employment rights.
Possible values: [HOURLY, SALARIED]
The compensation period for the employment type. * SALARIED: Employees that are paid a fixed amount per year. * HOURLY: Employees that are paid a wage per hour worked.
Possible values: [PART-TIME, FULL-TIME, TEMPORARY]
The amount worked for the employment type. * FULL-TIME: Full-time is at least 30 hours per week. Full-time workers will typically be eligible for benefits. * PART-TIME: Part-time is less than 30 hours per week. These workers may be eligible for benefits, depending on company settings and hours worked. * TEMPORARY: These workers are hired on a temporary basis. You can specify how each worker with this employment type will be paid individually.
Possible values: [MALE, FEMALE, NONBINARY, UNDETERMINED, DIVERSE, DOES_NOT_APPLY, PREFER_NOT_TO_SAY]
The gender of the worker, if specified.
The worker's date of birth.
Possible values: [BLACK, BROWN, CHINESE, EURASIAN, INDIAN, INDIGENOUS, MALAY, WHITE, YELLOW, NOT_INFORMED, OTHER]
The identified race of the worker, if specified.
Possible values: [HISPANIC_OR_LATINO, WHITE, BLACK_OR_AFRICAN_AMERICAN, NATIVE_HAWAIIAN_OR_OTHER_PACIFIC_ISLANDER, ASIAN, AMERICAN_INDIAN_OR_ALASKA_NATIVE, TWO_OR_MORE_RACES, MIDDLE_EASTERN_OR_NORTH_AFRICAN, DECLINE_TO_SELF_IDENTIFY, AFRICAN, COLOURED, INDIAN, OTHER, PREFER_NOT_TO_SAY]
The identified ethnicity of the worker, if specified.
Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]
The countries that the worker has citizenship in.
The compensation package for the worker.
compensation
object
Identifier field
Record creation date
Record update date
The worker's ID.
The worker's details.
Expandable field
annual_compensation
object
The worker's annual compensation. This calculation assumes 40-hour work weeks for workers with an hourly wage.
The currency type, ex: USD, EUR, etc.
The decimal amount for the currency.
annual_salary_equivalent
object
The worker's annual salary equivalent, for insurance purposes. It will be equal to the worker's annual compensation, except for owners that are receiving no cashcompensation.
The currency type, ex: USD, EUR, etc.
The decimal amount for the currency.
hourly_wage
object
The worker's hourly wage. This calculation assumes 40-hour work weeks for workers with fixed compensation.
The currency type, ex: USD, EUR, etc.
The decimal amount for the currency.
monthly_compensation
object
The worker's monthly compensation. This calculation assumes 40-hour work weeks for workers with an hourly wage.
The currency type, ex: USD, EUR, etc.
The decimal amount for the currency.
on_target_commission
object
The worker's on-target commission.
The currency type, ex: USD, EUR, etc.
The decimal amount for the currency.
relocation_reimbursement
object
The worker's hourly wage. This calculation assumes 40-hour work weeks for workers with fixed compensation.
The currency type, ex: USD, EUR, etc.
The decimal amount for the currency.
signing_bonus
object
The worker's signing bonus.
The currency type, ex: USD, EUR, etc.
The decimal amount for the currency.
target_annual_bonus
object
The worker's target annual bonus amount.
The currency type, ex: USD, EUR, etc.
The decimal amount for the currency.
weekly_compensation
object
The worker's weekly compensation. This calculation assumes 40-hour work weeks for workers with an hourly wage.
The currency type, ex: USD, EUR, etc.
The decimal amount for the currency.
The worker's target annual bonus as a percent of annual compensation.
The worker's bonus schedule.
The payment type for an worker's compensation.
The payment terms for an worker's compensation.
Salary effective date
Possible values: [EXEMPT, NON_EXEMPT]
The worker's overtime exemption status.
The worker's assigned department.
department
object
Identifier field
Record creation date
Record update date
The name of the department.
The parent department.
The parent department.
Expandable field
Reference code of the department.
The identifier of departments in the department hierarchy ordered from parent department to child department.
List of departments in the department hierarchy. Refer department_hierarchy_ids for department hierarchy order.
Expandable field
The worker's assigned teams.
teams
object[]
The worker's assigned teams.
Expandable field
Identifier field
Record creation date
Record update date
The parent team
The name of the team.
The worker's title.
Title effective date
The level of the worker.
level
object
Identifier field
Record creation date
Record update date
The name of the level. Must be unique within the company or organization.
The parent level.
The parent level.
Expandable field
Global level is used to track the seniority of levels. The higher up a level is placed on the page, the more senior and higher-ranked the level. Global level is used in workflows, policies, and reports that use the level attribute (e.g., you can use Level Lookup to set up a workflow that notifies the nearest person in an worker's management chain at or above the specified level).
The description of the level.
The scope of responsibilities for the level.
The experience requirements for the level.
The rank of the level within its track.
The track associated with the level. Required during creation. Include global_level when changing it.
track
object
The track associated with the level, if it's not a global level.
Expandable field
Identifier field
Record creation date
Record update date
The name of the track. Must be unique within the company or organization.
Whether this is the company's default track.
The one-based horizontal display order of the track.
The highest global level occupied by this track. Empty tracks return null.
ID of the worker's job function.
job_function
object
Identifier field
Record creation date
Record update date
Displayed name of the job function
termination_details
object
Possible values: [VOLUNTARY, INVOLUNTARY, RETIREMENT, DEATH, ABANDONMENT, OFFER_DECLINED, RESCIND, RENEGE]
The termination type indicates whether the termination was voluntary or involuntary.
This is a description that will be custom to each Rippling company.
The ID of the pay schedule currently associated with the worker.
work_schedule
object
The worker's scheduled working hours for each day of the week.
property name*
WorkScheduleDay
The scheduled working hours for a day of the week.
The number of scheduled working hours for the day.
compensation_grade
object
The compensation grade assigned to a worker.
The compensation grade's unique identifier.
The compensation grade's label.
The worker's earliest start date across their employment history, excluding INIT roles.
Custom field values defined on the Employee object for this worker
Expandable field
country_fields
object
us
object
Country-wise regional fields for USA
Social Security Number (SSN) for US employees.
ca
object
Country-wise regional fields for Canada
Social Insurance Number (SIN) for Canada employees.
nz
object
Country-wise regional fields for New Zealand
Inland Revenue Department (IRD) number for New Zealand employees.
Worker's assigned business partners unique identifiers. Returns an empty list ([]) if the worker has no business partners.
business_partners
object[]
Worker's assigned business partners. This field is only populated when explicitly requested via the expand parameter (e.g., ?expand=business_partners). When expanded, returns an empty list ([]) if the worker has no business partners.
Expandable field
Identifier field
Record creation date
Record update date
Identifier of business partner group the business parter is a part of
business_partner_group
object
Identifier field
Record creation date
Record update date
Name used to identify business partner group
Possible values: [HR, IT, FINANCE, RECRUITING, OTHER]
Type of business partner group
Id of Optional default business partner worker to whom all employees will be mapped if not explicitly mapped to a business partner in the group.
Optional default business partner worker to whom all employees will be mapped if not explicitly mapped to a business partner in the group.
Expandable field
Identifier of worker who is the business partner
Identifier of group of workers associated with the business partner
client_group
object
Identifier field
Record creation date
Record update date
The group's display name.
The group's name.
The id of the group's app owner.
The group type
The sub group type
Whether the group is read only.
The group's description.
The group's parent.
The group's mutually exclusive key
Whether the group is the cumulatively exhaustive default
Whether the group include terminated roles
Whether the group allows non employees
Whether the group can override role states
The group's priority when calculating mutual exclusivity
Whether the group is invisible
Whether to ignore provisioning group matching when determining group membership
Number of workers associated with the business partner