For AI agents: an index of this documentation is at https://developer.rippling.com/llms.txt. Public pages have a Markdown version at the same URL with .md added.

Skip to main content
Article

ActivityLogEvent

One visible Activity Log event retained from the last 90 days.

Use with AI:Rippling AI ChatGPT Claude Cursor

ActivityLogEvent

One visible Activity Log event retained from the last 90 days.

    id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    occurred_at string

    The activity occurrence time as an ISO 8601 UTC timestamp. Unlike created_at, which records when the Activity Log record was persisted, occurred_at records when the underlying activity happened.

    event_type string

    The open UPPER_SNAKE_CASE Activity Log code, such as USER_LOGIN_SUCCESS. New codes can appear over time.

    status string

    Possible values: [SUCCESS, FAILURE]

    The outcome of the activity. SUCCESS means the activity completed successfully; FAILURE means the activity failed. Null when no outcome was recorded.

    actor_type string

    Possible values: [WORKER, SYSTEM, EXTERNAL, INTERNAL_BY_WORKER, RIPPLING_MDM, PARTNER, PROXY]

    The kind of actor that initiated the event. WORKER is a Rippling worker; INTERNAL_BY_WORKER is an internal API request triggered by a worker; SYSTEM is an automated Rippling system process; EXTERNAL is an external system or integration; RIPPLING_MDM is Rippling MDM; PARTNER is a Rippling partner, but the partner identity is not returned; and PROXY is Rippling staff or support acting through proxy. Null when no actor type was recorded.

    worker_id string

    The Platform worker ID from GET /workers/{id}/ when the actor is a worker. Null when the actor is not a worker.

    worker

    object

    id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    user_id string

    The worker's associated user.

    user

    object

    The worker's associated user.

    Expandable field

    id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    active boolean

    Whether the user is able to access company resources, typically when they are in actively engaged with the company and not after off-boarding.

    username string

    The unique identifier across Rippling used by the User for direct authentication into their associated company. Globally unique.

    name

    object

    The user's name.

    formatted string

    The user's full name.

    given_name string

    The given legal name of the user, or first name in most Western languages.

    middle_name string

    The middle name(s) of the user.

    family_name string

    The legal family name of the user, or last name in most Western languages.

    preferred_given_name string

    The preferred given name, or first name in most Western languages, by the user.

    preferred_family_name string

    The preferred family name, or last name in most Western languages, by the user.

    display_name string

    The display name of the user using either the concatenated preferred given and family name or username depending on availability.

    emails

    object[]

    The user's email addresses.

  • Array [

  • value string

    A valid email address.

    type string

    Possible values: [HOME, WORK, OTHER]

    The classification of the email.

    display string

    The display value of the email address.

  • ]

  • phone_numbers

    object[]

    The user's phone numbers.

  • Array [

  • value string

    The canonical global phone number pursuant to RFC3966.

    type string

    Possible values: [HOME, WORK, MOBILE, FAX, OTHER]

    The classification of the phone number, pursuant to SCIM RFC 7643 4.1.2.

    display string

    The display value of the phone number.

  • ]

  • addresses

    object[]

    The user's addresses.

  • Array [

  • type string

    Possible values: [HOME, WORK, OTHER]

    The classification of the address.

    formatted string

    The formatted mailing address.

    street_address string

    The full street address component, which may include house number, street name, P.O. box, and multi-line extended street address information, pursuant to SCIM RFC 7643 4.1.2..

    locality string

    The city or locality component.

    region string

    The state or region component, pursuant to SCIM RFC 7643 4.1.2.

    postal_code string

    The zip code or postal code component, pursuant to SCIM RFC 7643 4.1.2.

    country string

    Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]

    The country component, pursuant to SCIM RFC 7643 4.1.2.

  • ]

  • photos

    object[]

    The user's photos.

  • Array [

  • value string

    The URL of the photo.

    type string

    Possible values: [PHOTO, THUMBNAIL]

    The classification of the photo.

  • ]

  • preferred_language string

    The User's preferred written or spoken language in the same format of the HTTP Accept-Language header, pursuant to Section 5.3.5 of RFC7231.

    locale string

    The User's default location for purposes of localization of currency, date time format, or numerical representations pursuant to RFC5646.

    timezone string

    The User's current time zone in IANA database Olson format

    number string

    The permanent profile number of the user.

    is_manager boolean

    Whether the worker is a manager

    manager_id string

    The worker's manager.

    manager object

    The worker's manager.

    Expandable field

    legal_entity_id string

    The worker's associated legal entity.

    legal_entity

    object

    The worker's associated legal entity.

    Expandable field

    id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    tax_identifier string

    The tax identifier for the legal entity.

    country

    object

    The country the legal entity is based in.

    code stringrequired

    Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]

    The code of the country.

    legal_name string

    The legal name of the legal entity.

    entity_level string

    Possible values: [PARENT, SUBSIDIARY, BRANCH]

    The legal entity's level in a hierarchy. * PARENT: The legal entity is considered the ultimate holding entity. * SUBSIDIARY: The legal entity is considered a subsidiary, fully or partially held by another. * BRANCH: The legal entity is considered a branch, associated with a parent legal entity.

    registration_date string

    The registration date of the entity.

    mailing_address

    object

    The mailing address of the legal entity.

    type string

    Possible values: [HOME, WORK, OTHER]

    The classification of the address.

    formatted string

    The formatted mailing address.

    street_address string

    The full street address component, which may include house number, street name, P.O. box, and multi-line extended street address information, pursuant to SCIM RFC 7643 4.1.2..

    locality string

    The city or locality component.

    region string

    The state or region component, pursuant to SCIM RFC 7643 4.1.2.

    postal_code string

    The zip code or postal code component, pursuant to SCIM RFC 7643 4.1.2.

    country string

    Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]

    The country component, pursuant to SCIM RFC 7643 4.1.2.

    physical_address

    object

    The physical address of the legal entity, if it differs from the mailing address.

    type string

    Possible values: [HOME, WORK, OTHER]

    The classification of the address.

    formatted string

    The formatted mailing address.

    street_address string

    The full street address component, which may include house number, street name, P.O. box, and multi-line extended street address information, pursuant to SCIM RFC 7643 4.1.2..

    locality string

    The city or locality component.

    region string

    The state or region component, pursuant to SCIM RFC 7643 4.1.2.

    postal_code string

    The zip code or postal code component, pursuant to SCIM RFC 7643 4.1.2.

    country string

    Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]

    The country component, pursuant to SCIM RFC 7643 4.1.2.

    parent_id string

    The parent legal entity.

    parent object

    The parent legal entity.

    Expandable field

    management_type string

    Possible values: [PEO, EOR, COR]

    The legal entity management type in the case of an employer of record (EOR) or professional employment organization (PEO). * PEO: The legal entity is considered a Professional Employment Organization (PEO). * EOR: The legal entity is considered an Employer of Record (EOR).

    company_id string

    The company or organization associated with the legal entity

    company

    object

    The company or organization associated with the legal entity

    Expandable field

    id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    parent_legal_entity_id string

    The company's ultimate holding entity.

    parent_legal_entity object

    The company's ultimate holding entity.

    Expandable field

    legal_entities_id string[]required

    A list of the company's entities.

    legal_entities arrayrequired

    A list of the company's entities.

    Expandable field

    physical_address

    object

    The physical address of the holding entity.

    type string

    Possible values: [HOME, WORK, OTHER]

    The classification of the address.

    formatted string

    The formatted mailing address.

    street_address string

    The full street address component, which may include house number, street name, P.O. box, and multi-line extended street address information, pursuant to SCIM RFC 7643 4.1.2..

    locality string

    The city or locality component.

    region string

    The state or region component, pursuant to SCIM RFC 7643 4.1.2.

    postal_code string

    The zip code or postal code component, pursuant to SCIM RFC 7643 4.1.2.

    country string

    Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]

    The country component, pursuant to SCIM RFC 7643 4.1.2.

    primary_email string

    The email address used when registering this company.

    legal_name string

    The legal name of the company.

    doing_business_as_name string

    The doing business as name for the company.

    phone string

    The phone number for the company.

    name stringrequired

    The name of the company.

    country string

    Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]

    The worker's country.

    start_date string

    The start date of the worker.

    end_date string

    The end date of the worker.

    number integer

    The worker's number within the organization.

    work_email string

    The worker's associated work email address.

    personal_email string

    The worker's associated personal email address.

    status string

    Possible values: [INIT, HIRED, ACCEPTED, ACTIVE, TERMINATED]

    The worker's status within the organization.

    location

    object

    The location that the worker is mapped to for tax purposes. In the case that a worker is remote, the location's type is remote.

    type stringrequired

    Possible values: [REMOTE, WORK]

    The type of location.

    work_location_id stringrequired

    The work location, if the worker isn't remote.

    employment_type_id string

    The worker's employment type.

    employment_type

    object

    The worker's employment type.

    Expandable field

    id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    label stringrequired

    The display label of the employment type.

    name string

    The name of the employment type for non-custom employment types.

    type string

    Possible values: [CONTRACTOR, EMPLOYEE]

    The classification of the worker by the company. * CONTRACTOR: Contractors are self-employed workers who provide services on a short-term or per-project basis and are not eligible for tax-withholding or benefits. * EMPLOYEE: Employees are hired and managed by an employer, work under the employer's direct supervision and control, and are protected by law for wages and employment rights.

    compensation_time_period string

    Possible values: [HOURLY, SALARIED]

    The compensation period for the employment type. * SALARIED: Employees that are paid a fixed amount per year. * HOURLY: Employees that are paid a wage per hour worked.

    amount_worked string

    Possible values: [PART-TIME, FULL-TIME, TEMPORARY]

    The amount worked for the employment type. * FULL-TIME: Full-time is at least 30 hours per week. Full-time workers will typically be eligible for benefits. * PART-TIME: Part-time is less than 30 hours per week. These workers may be eligible for benefits, depending on company settings and hours worked. * TEMPORARY: These workers are hired on a temporary basis. You can specify how each worker with this employment type will be paid individually.

    gender string

    Possible values: [MALE, FEMALE, NONBINARY, UNDETERMINED, DIVERSE, DOES_NOT_APPLY, PREFER_NOT_TO_SAY]

    The gender of the worker, if specified.

    date_of_birth string

    The worker's date of birth.

    race string

    Possible values: [BLACK, BROWN, CHINESE, EURASIAN, INDIAN, INDIGENOUS, MALAY, WHITE, YELLOW, NOT_INFORMED, OTHER]

    The identified race of the worker, if specified.

    ethnicity string

    Possible values: [HISPANIC_OR_LATINO, WHITE, BLACK_OR_AFRICAN_AMERICAN, NATIVE_HAWAIIAN_OR_OTHER_PACIFIC_ISLANDER, ASIAN, AMERICAN_INDIAN_OR_ALASKA_NATIVE, TWO_OR_MORE_RACES, MIDDLE_EASTERN_OR_NORTH_AFRICAN, DECLINE_TO_SELF_IDENTIFY, AFRICAN, COLOURED, INDIAN, OTHER, PREFER_NOT_TO_SAY]

    The identified ethnicity of the worker, if specified.

    citizenship string

    Possible values: [AF, AX, AL, DZ, AS, AD, AO, AI, AQ, AG, AR, AM, AW, AU, AT, AZ, BS, BH, BD, BB, BY, BE, BZ, BJ, BM, BT, BO, BQ, BA, BW, BV, BR, IO, BN, BG, BF, BI, CV, KH, CM, CA, KY, CF, TD, CL, CN, CX, CC, CO, KM, CG, CD, CK, CR, CI, HR, CW, CY, CZ, DK, DJ, DM, DO, EC, EG, SV, GQ, ER, EE, SZ, ET, FK, FO, FJ, FI, FR, GF, PF, TF, GA, GM, GE, DE, GH, GI, GR, GL, GD, GP, GU, GT, GG, GN, GW, GY, HT, HM, VA, HN, HK, HU, IS, IN, ID, IQ, IR, IE, IM, IL, IT, JM, JP, JE, JO, KZ, KE, KI, KR, XK, KW, KG, LA, LV, LB, LS, LR, LY, LI, LT, LU, MO, MG, MW, MY, MV, ML, MT, MH, MQ, MR, MU, YT, MX, FM, MD, MC, MN, ME, MS, MA, MZ, MM, NA, NR, NP, NL, AN, NC, NZ, NI, NE, NG, NU, NF, MK, MP, NO, OM, PK, PW, PS, PA, PG, PY, PE, PH, PN, PL, PT, PR, QA, RO, RU, RW, RE, BL, SH, KN, LC, MF, PM, VC, WS, SM, ST, SA, SN, RS, SC, SL, SG, SX, SY, SK, SI, SB, SO, ZA, GS, SS, ES, LK, SD, SR, SJ, SE, CH, TW, TJ, TZ, TH, TL, TG, TK, TO, TT, TN, TR, TM, TC, TV, UG, UA, AE, GB, US, UM, UY, UZ, VU, VE, VN, VG, VI, WF, EH, YE, ZM, ZW]

    The countries that the worker has citizenship in.

    compensation_id string

    The compensation package for the worker.

    compensation

    object

    The compensation package for the worker.

    Expandable field

    id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    worker_id string

    The worker's ID.

    worker object

    The worker's details.

    Expandable field

    annual_compensation

    object

    The worker's annual compensation. This calculation assumes 40-hour work weeks for workers with an hourly wage.

    currency_type string

    The currency type, ex: USD, EUR, etc.

    value number

    The decimal amount for the currency.

    annual_salary_equivalent

    object

    The worker's annual salary equivalent, for insurance purposes. It will be equal to the worker's annual compensation, except for owners that are receiving no cashcompensation.

    currency_type string

    The currency type, ex: USD, EUR, etc.

    value number

    The decimal amount for the currency.

    hourly_wage

    object

    The worker's hourly wage. This calculation assumes 40-hour work weeks for workers with fixed compensation.

    currency_type string

    The currency type, ex: USD, EUR, etc.

    value number

    The decimal amount for the currency.

    monthly_compensation

    object

    The worker's monthly compensation. This calculation assumes 40-hour work weeks for workers with an hourly wage.

    currency_type string

    The currency type, ex: USD, EUR, etc.

    value number

    The decimal amount for the currency.

    on_target_commission

    object

    The worker's on-target commission.

    currency_type string

    The currency type, ex: USD, EUR, etc.

    value number

    The decimal amount for the currency.

    relocation_reimbursement

    object

    The worker's hourly wage. This calculation assumes 40-hour work weeks for workers with fixed compensation.

    currency_type string

    The currency type, ex: USD, EUR, etc.

    value number

    The decimal amount for the currency.

    signing_bonus

    object

    The worker's signing bonus.

    currency_type string

    The currency type, ex: USD, EUR, etc.

    value number

    The decimal amount for the currency.

    target_annual_bonus

    object

    The worker's target annual bonus amount.

    currency_type string

    The currency type, ex: USD, EUR, etc.

    value number

    The decimal amount for the currency.

    weekly_compensation

    object

    The worker's weekly compensation. This calculation assumes 40-hour work weeks for workers with an hourly wage.

    currency_type string

    The currency type, ex: USD, EUR, etc.

    value number

    The decimal amount for the currency.

    target_annual_bonus_percent number

    The worker's target annual bonus as a percent of annual compensation.

    bonus_schedule string

    The worker's bonus schedule.

    payment_type string

    The payment type for an worker's compensation.

    payment_terms string

    The payment terms for an worker's compensation.

    salary_effective_date string

    Salary effective date

    overtime_exemption string

    Possible values: [EXEMPT, NON_EXEMPT]

    The worker's overtime exemption status.

    department_id string

    The worker's assigned department.

    department

    object

    The worker's assigned department.

    Expandable field

    id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    name stringrequired

    The name of the department.

    parent_id string

    The parent department.

    parent object

    The parent department.

    Expandable field

    reference_code string

    Reference code of the department.

    department_hierarchy_id string[]

    The identifier of departments in the department hierarchy ordered from parent department to child department.

    department_hierarchy array

    List of departments in the department hierarchy. Refer department_hierarchy_ids for department hierarchy order.

    Expandable field

    teams_id string[]

    The worker's assigned teams.

    teams

    object[]

    The worker's assigned teams.

    Expandable field

  • Array [

  • id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    parent_id string

    The parent team

    parent object

    The parent team

    Expandable field

    name stringrequired

    The name of the team.

  • ]

  • title string

    The worker's title.

    title_effective_date string

    Title effective date

    level_id string

    The level of the worker.

    level

    object

    The level of the worker.

    Expandable field

    id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    name stringrequired

    The name of the level. Must be unique within the company or organization.

    parent_id string

    The parent level.

    parent object

    The parent level.

    Expandable field

    global_level integer

    Global level is used to track the seniority of levels. The higher up a level is placed on the page, the more senior and higher-ranked the level. Global level is used in workflows, policies, and reports that use the level attribute (e.g., you can use Level Lookup to set up a workflow that notifies the nearest person in an worker's management chain at or above the specified level).

    description string

    The description of the level.

    scope_of_responsibilities string

    The scope of responsibilities for the level.

    experience_requirements string

    The experience requirements for the level.

    rank integer

    The rank of the level within its track.

    track_id string

    The track associated with the level. Required during creation. Include global_level when changing it.

    track

    object

    The track associated with the level, if it's not a global level.

    Expandable field

    id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    name stringrequired

    The name of the track. Must be unique within the company or organization.

    is_default boolean

    Whether this is the company's default track.

    order integer

    The one-based horizontal display order of the track.

    start_global_level integer

    The highest global level occupied by this track. Empty tracks return null.

    job_function_id string

    ID of the worker's job function.

    job_function

    object

    The worker's job function. When expanded, this field requires job-functions.read.

    Expandable field

    id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    name string

    Displayed name of the job function

    termination_details

    object

    The details of the worker's termination, if applicable.

    type string

    Possible values: [VOLUNTARY, INVOLUNTARY, RETIREMENT, DEATH, ABANDONMENT, OFFER_DECLINED, RESCIND, RENEGE]

    The termination type indicates whether the termination was voluntary or involuntary.

    reason string

    This is a description that will be custom to each Rippling company.

    pay_schedule_id string

    The ID of the pay schedule currently associated with the worker.

    work_schedule

    object

    The worker's scheduled working hours for each day of the week.

    property name*

    WorkScheduleDay

    The scheduled working hours for a day of the week.

    hours number

    The number of scheduled working hours for the day.

    compensation_grade

    object

    The compensation grade assigned to the worker, if any.

    id string

    The compensation grade's unique identifier.

    label string

    The compensation grade's label.

    original_start_date string

    The worker's earliest start date across their employment history, excluding INIT roles.

    custom_fields array

    Custom field values defined on the Employee object for this worker

    Expandable field

    country_fields

    object

    Country level fields for the worker.

    us

    object

    Country-wise regional fields for USA

    ssn string

    Social Security Number (SSN) for US employees.

    ca

    object

    Country-wise regional fields for Canada

    sin string

    Social Insurance Number (SIN) for Canada employees.

    nz

    object

    Country-wise regional fields for New Zealand

    ird_number string

    Inland Revenue Department (IRD) number for New Zealand employees.

    business_partners_id string[]

    Worker's assigned business partners unique identifiers. Returns an empty list ([]) if the worker has no business partners.

    business_partners

    object[]

    Worker's assigned business partners. This field is only populated when explicitly requested via the expand parameter (e.g., ?expand=business_partners). When expanded, returns an empty list ([]) if the worker has no business partners.

    Expandable field

  • Array [

  • id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    business_partner_group_id stringrequired

    Identifier of business partner group the business parter is a part of

    business_partner_group

    object

    Business partner group the business partner is a part of

    Expandable field

    id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    name stringrequired

    Name used to identify business partner group

    domain string

    Possible values: [HR, IT, FINANCE, RECRUITING, OTHER]

    Type of business partner group

    default_business_partner_id string

    Id of Optional default business partner worker to whom all employees will be mapped if not explicitly mapped to a business partner in the group.

    default_business_partner object

    Optional default business partner worker to whom all employees will be mapped if not explicitly mapped to a business partner in the group.

    Expandable field

    worker_id stringrequired

    Identifier of worker who is the business partner

    worker object

    Worker who is the business partner

    Expandable field

    client_group_id string

    Identifier of group of workers associated with the business partner

    client_group

    object

    Group of workers associated with the business partner

    Expandable field

    id stringrequired

    Identifier field

    created_at stringrequired

    Record creation date

    updated_at stringrequired

    Record update date

    display_name string

    The group's display name.

    name string

    The group's name.

    app_owner_id string

    The id of the group's app owner.

    group_type string

    The group type

    sub_group_type string

    The sub group type

    read_only boolean

    Whether the group is read only.

    description string

    The group's description.

    parent string

    The group's parent.

    mutually_exclusive_key string

    The group's mutually exclusive key

    cumulatively_exhaustive_default boolean

    Whether the group is the cumulatively exhaustive default

    include_terminated boolean

    Whether the group include terminated roles

    allow_non_employees boolean

    Whether the group allows non employees

    can_override_role_states boolean

    Whether the group can override role states

    priority integer

    The group's priority when calculating mutual exclusivity

    is_invisible boolean

    Whether the group is invisible

    ignore_prov_group_matching boolean

    Whether to ignore provisioning group matching when determining group membership

    client_group_member_count integer

    Number of workers associated with the business partner

  • ]

  • targets

    object[]

    The resources affected by the activity. Empty when no targets were recorded.

  • Array [

  • type string

    Possible values: [WORKER, SPOKE, RPASS_ITEM, SPOKE_USER, GROUP, RPASS_FOLDER, SCHEDULED_CHANGE, COMPUTER, BDR_POLICY, AUTH_RULE, COMPANY_AUTH_RULE, DEVICE, USER_ACCOUNT, HARDWARE_SCRIPT, HARDWARE_CONFIGURATION, SOFTWARE_UPDATE, OS_SOFTWARE_UPDATE, WORK_EMAIL_POLICY, OFFBOARDING_POLICY, REMOTE_ACCESS_SESSION_OPTIONS, REMOTE_ACCESS_SESSION_ERROR_DETAILS]

    The kind of target. WORKER uses the worker ID from GET /workers/{id}/; DEVICE uses the device ID from GET /devices/{id}/; GROUP uses the group ID from GET /supergroups/{id}/; SPOKE_USER uses the app-user ID from GET /app-users/{id}/. COMPUTER is deprecated in favor of DEVICE and its ID is not a Platform resource ID. IDs for SPOKE, RPASS_ITEM, RPASS_FOLDER, SCHEDULED_CHANGE, BDR_POLICY, AUTH_RULE, COMPANY_AUTH_RULE, USER_ACCOUNT, HARDWARE_SCRIPT, HARDWARE_CONFIGURATION, SOFTWARE_UPDATE, OS_SOFTWARE_UPDATE, WORK_EMAIL_POLICY, OFFBOARDING_POLICY, REMOTE_ACCESS_SESSION_OPTIONS, and REMOTE_ACCESS_SESSION_ERROR_DETAILS are not Platform resource IDs.

    id string

    The ID of the resource affected by the event. Null when the event target has no referenced resource. Filtering by targets.id is not supported for GROUP or SPOKE_USER targets.

  • ]

  • source_app_handle string

    The public app handle used by GET /app-users/ for the Rippling app associated with the activity. Null when the activity is not app-specific.

    reason

    object

    The recorded reason for an Activity Log event.

    code string

    The machine-readable reason code recorded for the event. Null when no reason was recorded.

    message string

    The human-readable meaning of the reason code. Null when no reason was recorded.

    request_context

    object

    Request and IP-derived location details recorded for an Activity Log event.

    ip_address string

    The IPv4 or IPv6 address associated with the request. Null without the activity-log.sensitive-data.read scope.

    device string

    The device family parsed from the request user agent. Returned with the activity-log.read scope. Null when unavailable.

    browser string

    The browser family parsed from the request user agent. Returned with the activity-log.read scope. Null when unavailable.

    operating_system string

    The operating system parsed from the request user agent. Returned with the activity-log.read scope. Null when unavailable.

    city string

    The city resolved from the request IP address. Null without the activity-log.sensitive-data.read scope or when geolocation is unresolved.

    state string

    The state or region resolved from the request IP address. Null without the activity-log.sensitive-data.read scope or when geolocation is unresolved.

    country string

    The country resolved from the request IP address. Null without the activity-log.sensitive-data.read scope or when geolocation is unresolved.

    latitude number

    The approximate latitude in decimal degrees resolved from the request IP address. Null without the activity-log.sensitive-data.read scope or when geolocation is unresolved.

    longitude number

    The approximate longitude in decimal degrees resolved from the request IP address. Null without the activity-log.sensitive-data.read scope or when geolocation is unresolved.

    accuracy_radius number

    The accuracy radius of the IP-derived location in kilometers. Null without the activity-log.sensitive-data.read scope or when geolocation is unresolved.